Go to Content



bada C++ Application

Home > Forums > English Forum > bada C++ Application

Quick Navigation

forum board View
deployment problem
selman@ / Jan, 13, 2011 14:31  
Hi

i have a problem in deploymnet -- run as "bada target applicatiom" -- stage

i have setup correct device driver for samsung mobile modem then
i have installet test root certificate then
i have set the phone connectivity settings to "usb debuggin" at my bada 1.0.0 OS phone
my manifest file is downloaded from bada site and its bada version is 1.0.0 but my sdk is 1.2.0 and uses 1.2.0 LP

whenever i click on run as - bada target application and it warned me as there is no binary. then i compiled for bada target application profile then i tried again

this time it was compiled and tried to launch but it hans at 69% at "launching: debugging Target c++ application"

my console output is:

Connected to the bada IDE.

 

The "COM6" port is open.

 

The "COM7" port is open.

 

8,0,0,1,2011-01-13,16:20:17.903,GT-S8500

 

8,0,0,1,2011-01-13,16:20:17.903,OK

 

8,0,0,1,2011-01-13,16:20:17.929,+LCDINFO: 480,800

 

8,0,0,1,2011-01-13,16:20:17.929,OK

 

8,0,0,1,2011-01-13,16:20:17.933,ERROR

 

8,0,0,1,2011-01-13,16:20:18.519,+GETDPIMG:0,OK



it hangs at 69%. what is my problem ? what i should i do? by the way at final stage will i use my application at my phone without sending to samsung cerfication and selling center. ? In other words, i want to use my application without sending to samsung. is it possible?

achaibada@ / Jan, 14, 2011 05:33 Post : #1

To run wave device (GT-S8500), device firmware should be compatible with the corresponding SDK.
Hence you need to upgrade your device to the latest firmware version and check whether same problem occurs.

elsergiator@ / Feb, 10, 2011 18:32 Post : #2
Hi!!


I have that problem with Wave S8530, sdk 1.2, device driver ok (wave II got from bada IDE 1.2.1).

The point is that when i got the s8530, i  tried to upgrade firmware with Kies since it detected there was a newer version, but there was an error, so i had to recover the previous firmware version (all done with the Kies upgrad interface, emergency recover and that stuff). Now, kies detects that my cell phone has the newest version, althought it doesn't since the original was was restored.

any idea how i could solve this? maybe forcing a firmware update with the same version? any idea how to do that with kies?


Did u solve your problem with the upgrade? was it a s8500 or s8530??

THX!!
akbada123@ / Feb, 11, 2011 04:41 Post : #3

Have you tried upgrading your device through samsung kies (new version) which is available at http://samsungapps.com/ ->Download kies?

And also refer to

1)      http://developer.bada.com/badaforum/board/thread/view.do?boardName=developer-site&messageId=29446

2)      http://developer.bada.com/badaforum/board/thread/view.do?boardName=ide-sdk&messageId=29411

kiendreamz@ / Mar, 08, 2011 07:12 Post : #4

My application works fine on Wave device. But when I run same application on Wave 525 devices, device get crash.

anandanil_kumar@ / Mar, 08, 2011 07:25 Post : #5

If you are using 1.2 SDK then you need to do some changes in SDK.

For building WQVGA devices (Wave 525, Wave 533) in bada SDK 1.2:

        1.       Your projects manifest.xml should have API version 1.1

2.       And in Project-Settings-bada Build, choose Model as WaveWQ_LP1.

 

karmeng_lau@ / Jun, 04, 2011 10:47 Post : #6
how to upgrade my s8530?